Jump to content
Sign in to follow this  
TDImk3

No spark on old suzuki??

Recommended Posts

Hi im new here but I have a question. Im potentialy looking at a 82 suzuki gs 450(yes its lame, but im broke:() and its in great condition, with low miles and very few owners. The current owner says it was a great running bike but now has no spark? It still has great compression just no spark?

What could cause this? Would it be a cheap or expensive part?

Thanks In advance

Joey

Share this post


Link to post
Share on other sites

Generally, that would mean it needs new plugs but I have a feeling that there is more to it than that

Share this post


Link to post
Share on other sites

No spark is usualy a lot easier and cheaper to fix than no compression. First things first. Check all fuses. Thats your most likely suspect. If the fuses are all good, then put new plugs in. Still no luck, find a manual or some way of getting a wire diagram. That age bike should be easy to find parts really cheap on ebay. The ignition coil or controller are bout the only things left to be bad.

Share this post


Link to post
Share on other sites

Ok thanks guys^^^

Does it sound like a good deal for around $300?

Its about all i can spend right now.

Share this post


Link to post
Share on other sites

you could buy it for 300 and part it out and make a profit

If it was running and now it has no spark, he prolly fouled the plugs since it's carbed it is highly probable

Share this post


Link to post
Share on other sites

for $300 I'd have a hard time turning it down. I just got an 89 zx600 with the intent of either a quick fix and something to ride, or double it in parts. I'd be you could have it running for less than a hundred or two if you like it enough.

Share this post


Link to post
Share on other sites

I dunno if those had points or not. Either way it shouldn't be too hard to fix.

Share this post


Link to post
Share on other sites
Hi im new here but I have a question. Im potentialy looking at a 82 suzuki gs 450(yes its lame, but im broke:() and its in great condition, with low miles and very few owners. The current owner says it was a great running bike but now has no spark? It still has great compression just no spark?

What could cause this? Would it be a cheap or expensive part?

Thanks In advance

Joey

could be plug, coil, cdi, or stator.

check in this order:

Is hi volt coming from coil pack? if yes, replace plug

if No, is low volt going into coil back primary side? if yes, replace coil pack

If No, is voltage going into CDI from stator? If yes, replace CDI

If No, replace stator/generator in the engine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×